summaryrefslogtreecommitdiff
path: root/desktop.nix
diff options
context:
space:
mode:
authorJulian T <julian@jtle.dk>2021-03-31 10:20:16 +0200
committerJulian T <julian@jtle.dk>2021-03-31 10:20:16 +0200
commit32e446e829159931bfe254899b2871e0afcf6a8d (patch)
treea43aa036090b31429582b68d8d0b213b2ad1d2f3 /desktop.nix
parentdedff3809b3d0bca1ad309cfb6e7648b029485f4 (diff)
Switch to stable release and disable the pulseaudio cork module
Diffstat (limited to 'desktop.nix')
-rw-r--r--desktop.nix16
1 files changed, 11 insertions, 5 deletions
diff --git a/desktop.nix b/desktop.nix
index 4882cf7..5a5d358 100644
--- a/desktop.nix
+++ b/desktop.nix
@@ -9,6 +9,11 @@
# Enable bluetooth audio
package = pkgs.pulseaudioFull;
+
+ # Disable cork module
+ configFile = pkgs.runCommand "default.pa" {} ''
+ grep -v module-role-cork ${config.hardware.pulseaudio.package}/etc/pulse/default.pa > $out
+ '';
};
bluetooth.enable = true;
@@ -100,32 +105,33 @@
gopass stow pass gnupg imagemagick acpi gdb sox
# Nixos stuff
- nox
+ nox nix-index
# Network stuff
networkmanagerapplet networkmanager-openconnect iw
wirelesstools
# Developing
- rustup gcc go clang-tools
+ rustup gcc go clang-tools python38Packages.ipython
# X stuff
feh rofi xorg.xmodmap xss-lock xclip xorg.xkill
acpilight xdotool dunst xcompmgr scrot libnotify i3lock
+ xbindkeys
# Gui applications
firefox pavucontrol evince leafpad inkscape gimp
meld pinentry gnome3.gnome-system-monitor
termite quasselClient wireshark spotify
gnome3.file-roller gnome3.gnome-calculator
- gnome3.simple-scan vlc mpv xorg.xev tor-browser-bundle-bin
- evolution evolution-data-server vimHugeX
+ gnome3.simple-scan vlc mpv xorg.xev
+ gnome3.evolution evolution-data-server vimHugeX
(mumble.override { pulseSupport = true; })
libreoffice-fresh liferea qutebrowser mate.caja
# Other stuff
texlive.combined.scheme-medium biber
youtube-dl sshpass python38Packages.pynvim
- aspellDicts.da aspellDicts.en
+ aspell aspellDicts.da aspellDicts.en
];
}