summaryrefslogtreecommitdiff
path: root/desktop.nix
diff options
context:
space:
mode:
authorJulian T <julian@jtle.dk>2021-03-28 00:24:28 +0100
committerJulian T <julian@jtle.dk>2021-03-28 00:24:28 +0100
commitdedff3809b3d0bca1ad309cfb6e7648b029485f4 (patch)
tree2c56d1e81e11396e09d27efeb56b08cbf4a33061 /desktop.nix
parentea6c7b65ba32b4be09ef4c7a8532b239c03f120d (diff)
Move more things from core to desktop, and add iso file
Diffstat (limited to 'desktop.nix')
-rw-r--r--desktop.nix51
1 files changed, 44 insertions, 7 deletions
diff --git a/desktop.nix b/desktop.nix
index 136b35c..4882cf7 100644
--- a/desktop.nix
+++ b/desktop.nix
@@ -1,15 +1,23 @@
{ config, pkgs, ... }:
{
- hardware.pulseaudio = {
- enable = true;
- # Stupid but need it to control sound from acpid
- # systemWide = true;
+ hardware = {
+ pulseaudio = {
+ enable = true;
+ # Stupid but need it to control sound from acpid
+ # systemWide = true;
+
+ # Enable bluetooth audio
+ package = pkgs.pulseaudioFull;
+ };
+
+ bluetooth.enable = true;
- # Enable bluetooth audio
- package = pkgs.pulseaudioFull;
+ opengl.enable = true;
};
+ sound.enable = true;
+
services = {
xserver = {
enable = true;
@@ -58,8 +66,28 @@
GRANT ALL PRIVILEGES ON DATABASE julian TO julian;
'';
};
+
+ blueman.enable = true;
+
+ udev.packages = [ pkgs.yubikey-personalization ];
};
+ programs = {
+ gnupg.agent = {
+ enable = true;
+ enableSSHSupport = true;
+ pinentryFlavor = "gtk2";
+ };
+
+ dconf.enable = true;
+ };
+
+ # Define a user account. Don't forget to set a password with ‘passwd’.
+ users.users.julian = {
+ isNormalUser = true;
+ shell = pkgs.zsh;
+ extraGroups = [ "wheel" "video" "vboxusers" "cdrom" ];
+ };
virtualisation.virtualbox.host.enable = true;
@@ -68,7 +96,15 @@
];
environment.systemPackages = with pkgs; [
- gopass
+ # General stuff
+ gopass stow pass gnupg imagemagick acpi gdb sox
+
+ # Nixos stuff
+ nox
+
+ # Network stuff
+ networkmanagerapplet networkmanager-openconnect iw
+ wirelesstools
# Developing
rustup gcc go clang-tools
@@ -90,5 +126,6 @@
# Other stuff
texlive.combined.scheme-medium biber
youtube-dl sshpass python38Packages.pynvim
+ aspellDicts.da aspellDicts.en
];
}