aboutsummaryrefslogtreecommitdiff
path: root/shells/pymath.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shells/pymath.nix')
-rw-r--r--shells/pymath.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/shells/pymath.nix b/shells/pymath.nix
new file mode 100644
index 0000000..5fa8b1e
--- /dev/null
+++ b/shells/pymath.nix
@@ -0,0 +1,16 @@
+{ pkgs ? import <nixpkgs> {}, pythonPackages ? pkgs.python38Packages }:
+
+pkgs.mkShell {
+ buildInputs = with pythonPackages; [
+ jupyterlab
+ jupyter-c-kernel
+ numpy
+ scipy
+ matplotlib
+ ];
+
+ shellHook = ''
+ echo Lets do some python
+ alias start="jupyter lab"
+ '';
+}