aboutsummaryrefslogtreecommitdiff
path: root/shells/pymath.nix
diff options
context:
space:
mode:
authorJulian T <julian@jtle.dk>2021-04-06 13:04:14 +0200
committerJulian T <julian@jtle.dk>2021-04-06 13:04:14 +0200
commit392e56bcebdbc391e1c63bdaebc2f9e89270f1f8 (patch)
tree30c5481ec7025b57a794c6078c037b5015f9b4bb /shells/pymath.nix
parent2f9442097a47ef7c330207ea6363db63f044a192 (diff)
Add nix-shell and prob things
Diffstat (limited to 'shells/pymath.nix')
-rw-r--r--shells/pymath.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/shells/pymath.nix b/shells/pymath.nix
new file mode 100644
index 0000000..5fa8b1e
--- /dev/null
+++ b/shells/pymath.nix
@@ -0,0 +1,16 @@
+{ pkgs ? import <nixpkgs> {}, pythonPackages ? pkgs.python38Packages }:
+
+pkgs.mkShell {
+ buildInputs = with pythonPackages; [
+ jupyterlab
+ jupyter-c-kernel
+ numpy
+ scipy
+ matplotlib
+ ];
+
+ shellHook = ''
+ echo Lets do some python
+ alias start="jupyter lab"
+ '';
+}