summaryrefslogtreecommitdiff
path: root/pc_t14.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pc_t14.nix')
-rw-r--r--pc_t14.nix23
1 files changed, 21 insertions, 2 deletions
diff --git a/pc_t14.nix b/pc_t14.nix
index fa536f0..489b67d 100644
--- a/pc_t14.nix
+++ b/pc_t14.nix
@@ -23,11 +23,30 @@
};
};
+ initrd.kernelModules = [ "amdgpu" ];
};
- hardware.acpilight.enable = true;
+ hardware = {
+ acpilight.enable = true;
- services.tlp.enable = true;
+ opengl = {
+ driSupport = true;
+ driSupport32Bit = true;
+
+ extraPackages = with pkgs; [
+ amdvlk
+ ];
+
+ extraPackages32 = with pkgs; [
+ driversi686Linux.amdvlk
+ ];
+ };
+ };
+
+ services = {
+ tlp.enable = true;
+ xserver.videoDrivers = ["amdgpu"];
+ };
environment.systemPackages = with pkgs; [
linuxPackages.acpi_call