summaryrefslogtreecommitdiff
path: root/pc_t14.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pc_t14.nix')
-rw-r--r--pc_t14.nix35
1 files changed, 32 insertions, 3 deletions
diff --git a/pc_t14.nix b/pc_t14.nix
index 221e6ba..e72671c 100644
--- a/pc_t14.nix
+++ b/pc_t14.nix
@@ -1,7 +1,36 @@
-{ config, ... };
+{ config, pkgs, ... }:
{
- boot.loader.grub.device = "/dev/sda";
- networking.hostName = "nixT14s";
+ networking = {
+ hostName = "nixT14s";
+
+ interfaces.enp2s0f0.useDHCP = true;
+ interfaces.wlp3s0.useDHCP = true;
+ };
+
+ boot = {
+ kernelPackages = pkgs.linuxPackages_latest;
+ loader = {
+ systemd-boot.enable = true;
+
+ efi.canTouchEfiVariables = true;
+ efi.efiSysMountPoint = "/boot";
+ };
+ initrd.luks.devices = {
+ lvmroot = {
+ device = "/dev/disk/by-uuid/3aa2923c-928d-4050-82dc-21be53b2af8e";
+ preLVM = true;
+ };
+ };
+
+ };
+
+ hardware.acpilight.enable = true;
+
+ services.tlp.enable = true;
+
+ environment.systemPackages = with pkgs; [
+ linuxPackages.acpi_call
+ ];
}