summaryrefslogtreecommitdiff
path: root/pc_t14.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pc_t14.nix')
-rw-r--r--pc_t14.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/pc_t14.nix b/pc_t14.nix
index 5ae9b07..95c8999 100644
--- a/pc_t14.nix
+++ b/pc_t14.nix
@@ -8,6 +8,15 @@
interfaces.wlp3s0.useDHCP = true;
};
+ networking = {
+ # We want to NAT container traffic
+ nat = {
+ enable = true;
+ internalInterfaces = [ "ve-test" ];
+ externalInterface = "wlp3s0";
+ };
+ };
+
boot = {
kernelPackages = lib.mkIf (lib.versionOlder pkgs.linux.version "5.8") pkgs.linuxPackages_5_10;
loader = {
@@ -50,6 +59,8 @@
environment.systemPackages = with pkgs; [
linuxPackages.acpi_call
+
+ acpilight
];
}