summaryrefslogtreecommitdiff
path: root/desktop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'desktop.nix')
-rw-r--r--desktop.nix30
1 files changed, 15 insertions, 15 deletions
diff --git a/desktop.nix b/desktop.nix
index 2da180f..136b35c 100644
--- a/desktop.nix
+++ b/desktop.nix
@@ -1,14 +1,14 @@
{ config, pkgs, ... }:
{
- hardware.pulseaudio = {
- enable = true;
- # Stupid but need it to control sound from acpid
- # systemWide = true;
+ hardware.pulseaudio = {
+ enable = true;
+ # Stupid but need it to control sound from acpid
+ # systemWide = true;
- # Enable bluetooth audio
- package = pkgs.pulseaudioFull;
- };
+ # Enable bluetooth audio
+ package = pkgs.pulseaudioFull;
+ };
services = {
xserver = {
@@ -58,20 +58,20 @@
GRANT ALL PRIVILEGES ON DATABASE julian TO julian;
'';
};
- };
+ };
- virtualisation.virtualbox.host.enable = true;
+ virtualisation.virtualbox.host.enable = true;
fonts.fonts = with pkgs; [
noto-fonts noto-fonts-emoji liberation_ttf ubuntu_font_family cozette
];
- environment.systemPackages = with pkgs; [
- gopass
+ environment.systemPackages = with pkgs; [
+ gopass
- # Developing
- rustup gcc go clang-tools
+ # Developing
+ rustup gcc go clang-tools
# X stuff
feh rofi xorg.xmodmap xss-lock xclip xorg.xkill
@@ -90,5 +90,5 @@
# Other stuff
texlive.combined.scheme-medium biber
youtube-dl sshpass python38Packages.pynvim
- ];
-}
+ ];
+ }