summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix35
1 files changed, 17 insertions, 18 deletions
diff --git a/configuration.nix b/configuration.nix
index e410470..7bd3fde 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -5,20 +5,19 @@
{ config, pkgs, ... }:
{
- imports =
- [ # Include the results of the hardware scan.
- ./hardware-configuration.nix
- ./pc_t14.nix
- ./desktop.nix
- ];
-
- boot = {
- tmpOnTmpfs = true;
- supportedFilesystems = [ "ntfs" ];
- kernel.sysctl = {
+ imports = [
+ ./hardware-configuration.nix
+ ./pc_t14.nix
+ ./desktop.nix
+ ];
+
+ boot = {
+ tmpOnTmpfs = true;
+ supportedFilesystems = [ "ntfs" ];
+ kernel.sysctl = {
"kernel.sysrq"=1;
};
- };
+ };
# Enable sound.
sound.enable = true;
@@ -58,8 +57,8 @@
# services.openssh.enable = true;
programs = {
- ssh.startAgent = false;
- gnupg.agent = {
+ ssh.startAgent = false;
+ gnupg.agent = {
enable = true;
enableSSHSupport = true;
pinentryFlavor = "gtk2";
@@ -68,7 +67,7 @@
programs.dconf.enable = true;
services = {
- udev.packages = [ pkgs.yubikey-personalization ];
+ udev.packages = [ pkgs.yubikey-personalization ];
};
# Define a user account. Don't forget to set a password with ‘passwd’.
@@ -78,7 +77,7 @@
extraGroups = [ "wheel" "video" "vboxusers" "cdrom" ];
};
- virtualisation.docker.enable = false;
+ virtualisation.docker.enable = false;
# This value determines the NixOS release with which your system is to be
# compatible, in order to avoid breaking some software such as database
@@ -97,8 +96,8 @@
aspell aspellDicts.da aspellDicts.en pv acpi jq killall netcat-gnu perl gopass
cowsay gdb man-pages sox gcc binutils python3 python
- # Nixos stuff
- nox
+ # Nixos stuff
+ nox
# Network stuff
networkmanagerapplet networkmanager-openconnect iw batctl