summaryrefslogtreecommitdiff
path: root/core.nix
diff options
context:
space:
mode:
authorJulian T <julian@jtle.dk>2021-03-28 00:24:28 +0100
committerJulian T <julian@jtle.dk>2021-03-28 00:24:28 +0100
commitdedff3809b3d0bca1ad309cfb6e7648b029485f4 (patch)
tree2c56d1e81e11396e09d27efeb56b08cbf4a33061 /core.nix
parentea6c7b65ba32b4be09ef4c7a8532b239c03f120d (diff)
Move more things from core to desktop, and add iso file
Diffstat (limited to 'core.nix')
-rw-r--r--core.nix44
1 files changed, 4 insertions, 40 deletions
diff --git a/core.nix b/core.nix
index 7c71927..801a940 100644
--- a/core.nix
+++ b/core.nix
@@ -13,14 +13,8 @@
};
};
- # Enable sound.
- sound.enable = true;
-
hardware = {
- opengl.enable = true;
enableRedistributableFirmware = true;
-
- bluetooth.enable = false;
};
networking = {
@@ -50,29 +44,6 @@
# Enable the OpenSSH daemon.
# services.openssh.enable = true;
- programs = {
- ssh.startAgent = false;
- gnupg.agent = {
- enable = true;
- enableSSHSupport = true;
- pinentryFlavor = "gtk2";
- };
- };
- programs.dconf.enable = true;
-
- services = {
- udev.packages = [ pkgs.yubikey-personalization ];
- };
-
- # Define a user account. Don't forget to set a password with ‘passwd’.
- users.users.julian = {
- isNormalUser = true;
- shell = pkgs.zsh;
- extraGroups = [ "wheel" "video" "vboxusers" "cdrom" ];
- };
-
- virtualisation.docker.enable = false;
-
# This value determines the NixOS release with which your system is to be
# compatible, in order to avoid breaking some software such as database
# servers. You should change this only after NixOS release notes say you
@@ -85,17 +56,10 @@
environment = {
systemPackages = with pkgs; [
# General stuff
- wget vim neovim git htop zsh stow pass tree dnsutils gnupg zip
- unzip tig file imagemagick whois nmap usbutils lshw gnumake
- aspell aspellDicts.da aspellDicts.en pv acpi jq killall netcat-gnu perl gopass
- cowsay gdb man-pages sox gcc binutils python3 python
-
- # Nixos stuff
- nox
-
- # Network stuff
- networkmanagerapplet networkmanager-openconnect iw batctl
- wirelesstools
+ wget vim neovim git htop zsh tree dnsutils zip
+ unzip tig file whois nmap usbutils lshw gnumake
+ aspell pv jq killall netcat-gnu perl
+ cowsay man-pages gcc binutils python3 python
];
};
}