summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
authorJulian T <julian@jtle.dk>2021-03-26 23:23:00 +0100
committerJulian T <julian@jtle.dk>2021-03-26 23:23:59 +0100
commita6e54152bddf43600e5b9f83c187d3b3aee6411a (patch)
tree7327368a3319fa4fa9554304a494319b3b499d27 /configuration.nix
parent2e8fe8b92cc722fc10c9d9d18fabac9cb30ea3fc (diff)
Move everything into non configuration.nix files
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix107
1 files changed, 0 insertions, 107 deletions
diff --git a/configuration.nix b/configuration.nix
deleted file mode 100644
index 7bd3fde..0000000
--- a/configuration.nix
+++ /dev/null
@@ -1,107 +0,0 @@
-# Edit this configuration file to define what should be installed on
-# your system. Help is available in the configuration.nix(5) man page
-# and in the NixOS manual (accessible by running ‘nixos-help’).
-
-{ config, pkgs, ... }:
-
-{
- imports = [
- ./hardware-configuration.nix
- ./pc_t14.nix
- ./desktop.nix
- ];
-
- boot = {
- tmpOnTmpfs = true;
- supportedFilesystems = [ "ntfs" ];
- kernel.sysctl = {
- "kernel.sysrq"=1;
- };
- };
-
- # Enable sound.
- sound.enable = true;
-
- hardware = {
- opengl.enable = true;
- enableRedistributableFirmware = true;
-
- bluetooth.enable = false;
- };
-
- networking = {
- # Firewall configuration
- # firewall.enable = true; yeah who needs that shit
-
- networkmanager = {
- enable = true;
- };
- };
-
- # Select internationalisation properties.
- i18n = {
- defaultLocale = "en_DK.UTF-8";
- };
-
- console = {
- keyMap = "us";
- font = "Lat2-Terminus16";
- };
-
- # Set your time zone.
- time.timeZone = "Europe/Copenhagen";
-
- # Enabled services
-
- # Enable the OpenSSH daemon.
- # services.openssh.enable = true;
-
- programs = {
- ssh.startAgent = false;
- gnupg.agent = {
- enable = true;
- enableSSHSupport = true;
- pinentryFlavor = "gtk2";
- };
- };
- programs.dconf.enable = true;
-
- services = {
- udev.packages = [ pkgs.yubikey-personalization ];
- };
-
- # Define a user account. Don't forget to set a password with ‘passwd’.
- users.users.julian = {
- isNormalUser = true;
- shell = pkgs.zsh;
- extraGroups = [ "wheel" "video" "vboxusers" "cdrom" ];
- };
-
- virtualisation.docker.enable = false;
-
- # This value determines the NixOS release with which your system is to be
- # compatible, in order to avoid breaking some software such as database
- # servers. You should change this only after NixOS release notes say you
- # should.
- system.stateVersion = "21.05"; # Did you read the comment?
-
- # List packages installed in system profile. To search, run:
- # $ nix search wget
- nixpkgs.config.allowUnfree = true;
- environment = {
- systemPackages = with pkgs; [
- # General stuff
- wget vim neovim git htop zsh stow pass tree dnsutils gnupg zip
- unzip tig file imagemagick whois nmap usbutils lshw gnumake
- aspell aspellDicts.da aspellDicts.en pv acpi jq killall netcat-gnu perl gopass
- cowsay gdb man-pages sox gcc binutils python3 python
-
- # Nixos stuff
- nox
-
- # Network stuff
- networkmanagerapplet networkmanager-openconnect iw batctl
- wirelesstools
- ];
- };
-}