diff options
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 12 |
1 files changed, 9 insertions, 3 deletions
@@ -1,7 +1,13 @@ -{ pkgs ? import <nixpkgs> {}, pythonPackages ? pkgs.python38Packages }: +{ pkgs ? import <nixpkgs> {} +, python ? pkgs.python38 }: +let + pythonEnv = python.withPackages (pkgs: with pkgs; [ + jinja2 pillow pyyaml + ]); +in pkgs.mkShell { - buildInputs = with pythonPackages; [ - jinja2 pillow pyyaml pkgs.exiftool + buildInputs = [ + pythonEnv pkgs.exiftool ]; } |