summaryrefslogtreecommitdiff
path: root/desktop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'desktop.nix')
-rw-r--r--desktop.nix14
1 files changed, 10 insertions, 4 deletions
diff --git a/desktop.nix b/desktop.nix
index bd342d6..2f293d4 100644
--- a/desktop.nix
+++ b/desktop.nix
@@ -90,11 +90,14 @@
# Define a user account. Don't forget to set a password with ‘passwd’.
users.users.julian = {
isNormalUser = true;
- shell = pkgs.zsh;
- extraGroups = [ "wheel" "video" "vboxusers" "cdrom" ];
+ shell = pkgs.fish;
+ extraGroups = [ "wheel" "video" "libvirtd" "vboxusers" "cdrom" "networkmanager" ];
};
- virtualisation.virtualbox.host.enable = true;
+ virtualisation.virtualbox.host = {
+ enable = true;
+ };
+ virtualisation.libvirtd.enable = true;
fonts.fonts = with pkgs; [
noto-fonts noto-fonts-emoji liberation_ttf ubuntu_font_family cozette
@@ -102,7 +105,7 @@
environment.systemPackages = with pkgs; [
# General stuff
- gnupg acpi
+ gnupg acpi gutenprint gutenprintBin
# Nixos stuff
nox nix-index patchelf nix-prefetch-scripts
@@ -110,5 +113,8 @@
# Network stuff
networkmanagerapplet networkmanager-openconnect iw
wirelesstools openconnect
+
+ virtmanager
+
];
}