summaryrefslogtreecommitdiff
path: root/desktop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'desktop.nix')
-rw-r--r--desktop.nix94
1 files changed, 94 insertions, 0 deletions
diff --git a/desktop.nix b/desktop.nix
new file mode 100644
index 0000000..2da180f
--- /dev/null
+++ b/desktop.nix
@@ -0,0 +1,94 @@
+{ config, pkgs, ... }:
+
+{
+ hardware.pulseaudio = {
+ enable = true;
+ # Stupid but need it to control sound from acpid
+ # systemWide = true;
+
+ # Enable bluetooth audio
+ package = pkgs.pulseaudioFull;
+ };
+
+ services = {
+ xserver = {
+ enable = true;
+ layout = "us";
+ xkbVariant = "altgr-intl";
+ exportConfiguration = true;
+
+ windowManager = {
+ i3 = {
+ enable = true;
+ package = pkgs.i3-gaps;
+ };
+ };
+
+ displayManager = {
+ defaultSession = "none+i3";
+ };
+
+ desktopManager = {
+ xterm.enable = false;
+ };
+
+ # Touchpad studd
+ libinput.enable = true;
+
+ # Start dbus?
+ # startDbusSession = true;
+ };
+ # Auto mounting
+ gvfs.enable = true;
+
+ # Evolution
+ gnome3 = {
+ gnome-keyring.enable = true;
+ evolution-data-server.enable = true;
+ };
+
+ # Enable CUPS to print documents.
+ printing.enable = true;
+
+ postgresql = {
+ enable = false;
+ initialScript = pkgs.writeText "backend-initScript" ''
+ CREATE ROLE julian WITH LOGIN PASSWORD 'hejmeddig' CREATEDB;
+ CREATE DATABASE julian;
+ GRANT ALL PRIVILEGES ON DATABASE julian TO julian;
+ '';
+ };
+ };
+
+
+ virtualisation.virtualbox.host.enable = true;
+
+ fonts.fonts = with pkgs; [
+ noto-fonts noto-fonts-emoji liberation_ttf ubuntu_font_family cozette
+ ];
+
+ environment.systemPackages = with pkgs; [
+ gopass
+
+ # Developing
+ rustup gcc go clang-tools
+
+ # X stuff
+ feh rofi xorg.xmodmap xss-lock xclip xorg.xkill
+ acpilight xdotool dunst xcompmgr scrot libnotify i3lock
+
+ # Gui applications
+ firefox pavucontrol evince leafpad inkscape gimp
+ meld pinentry gnome3.gnome-system-monitor
+ termite quasselClient wireshark spotify
+ gnome3.file-roller gnome3.gnome-calculator
+ gnome3.simple-scan vlc mpv xorg.xev tor-browser-bundle-bin
+ evolution evolution-data-server vimHugeX
+ (mumble.override { pulseSupport = true; })
+ libreoffice-fresh liferea qutebrowser mate.caja
+
+ # Other stuff
+ texlive.combined.scheme-medium biber
+ youtube-dl sshpass python38Packages.pynvim
+ ];
+}